View Single Post
Old 29th February 2012, 15:49
tested0002 tested0002 is offline
Junior Member
Join Date: Feb 2012
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Smile Wordpress Error 500 on ISPConfig3.0.4.3 NGINX

Hi to all the members,Moderators and Admins of ISPConfig.

First of all I would like to thank you for the great software you have here. I came here because I search the forums but I couldn't find what really the great solution to my problem.

I have successfully installed ISPConfig 3 to my Centos 6.2 VPS with 1GB of RAM.
I use NGINX as my default web server. And the problem goes here. I upload wordpress files to my server and i have

1. Chown all the files to current user and group.
2. Removed the .htaccess file on the root directory.
3. Chmod files from 644 to 755 (tried also 777 but no luck, switch back to original permissions)

But I got ERROR 500 - Internal Server Error!... And I can't continue with the installation. By the way I put the wordpress files to root directory of my domain.

My current vhost.conf
server {
        listen *:80;

        server_name ;
        root   /var/www/;

        index index.html index.htm index.php index.cgi index.xhtml;

        error_page 400 /error/400.html;
        error_page 401 /error/401.html;
        error_page 403 /error/403.html;
        error_page 404 /error/404.html;
        error_page 405 /error/405.html;
        error_page 500 /error/500.html;
        error_page 502 /error/502.html;
        error_page 503 /error/503.html;

        error_log /var/log/ispconfig/httpd/;
        access_log /var/log/ispconfig/httpd/ combined;

        ## Disable .htaccess and other hidden files
        location ~ /\. {
            deny all;
            access_log off;
            log_not_found off;

        location = /favicon.ico {
            log_not_found off;
            access_log off;

        location = /robots.txt {
            allow all;
            log_not_found off;
            access_log off;

        location /stats {
            index index.html index.php;
            auth_basic "Members Only";
            auth_basic_user_file /var/www/clients/client3/web6/.htpasswd_stats;

        location /awstats-icon {
            alias /usr/share/awstats/icon;

        location ~ \.php$ {
           try_files $uri =404;
            include /etc/nginx/fastcgi_params;
            fastcgi_pass unix:/var/lib/php5-fpm/web6.sock;
            fastcgi_index index.php;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_param PATH_INFO $fastcgi_script_name;
            fastcgi_intercept_errors on;

I use this configuration on Joomla and It works without any problem. No error 500.

Please anyone here having this kind of problem and if you already fixed this please share it with us. Please if you need anymore info about my configuration please ask and I will post it again here.

Thank you
Reply With Quote
Sponsored Links