View Single Post
  #1  
Old 3rd February 2012, 15:18
link-m link-m is offline
Junior Member
 
Join Date: Dec 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Webserver created files have wrong permisions/owner

Hi,
I run ispconfig several users are on the system and everything is working fine, but...

Some users have wordpress installed and install plugins via the web interface. This way the webserver creates files on the hard disk in the web directory of the user.
These files have the ownership of www-data.www-data and not client1.web1 (just an example). As the webserver also creates directories the user is no longer able to delete these webserver created files.

Has anyone a solution to this problem other than running a cronjob the resets the permission of every file owned by the webserver every now and then?

As I ran my own selfmade hosting solution I had one apache instance for every user in chroot environment and that way all webserver created files had the correct ownership and permissions. But the ispconfig approach does not allow this, as far as I understand ispconfig...


Cheers,
Nicki
Reply With Quote
Sponsored Links