View Single Post
  #13  
Old 30th January 2012, 11:10
fxs fxs is offline
Junior Member
 
Join Date: Jan 2012
Posts: 27
Thanks: 2
Thanked 1 Time in 1 Post
Default

You have the apache.log above.

In addition, I saw in the apache.log the string:
Invalid method in request \x16\x03\x01
That means there is probably an arror in httpd.conf. The fix could be to specify the port in all of the VirtualHost & NameVirtualHost directives in the apache httpd config or something else.

Maybe it explains the lines (in apache.log):
Quote:
[Thu Jan 26 01:32:13 2012] [warn] Init: (xxxxxxx.ovh.net:443) You configured HTTP(80) on the standard HTTPS(443) port!
or
[warn] NameVirtualHost xxxxxx:80 has no Virtual Hosts
[Thu Jan 26 01:28:09 2012] [warn] NameVirtualHost xxxxxxxx:443 has no VirtualHosts
Is this file (port.conf) correct?
Code:
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    # If you add NameVirtualHost *:443 here, you will also have to change
    # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
    # to <VirtualHost *:443>
    # Server Name Indication for SSL named virtual hosts is currently not
    # supported by MSIE on Windows XP.
Listen 443
</IfModule>

<IfModule mod_gnutls.c>
Listen 443
</IfModule>
Thank you to give me your inputs
Reply With Quote