View Single Post
  #8  
Old 28th January 2012, 15:59
fredol fredol is offline
Junior Member
 
Join Date: Oct 2010
Posts: 7
Thanks: 3
Thanked 0 Times in 0 Posts
Default

The solution doesn't work for me.
I've edited /etc/courier/authmysqlrc as follows :

MYSQL_SERVER localhost
MYSQL_USERNAME xxx
MYSQL_PASSWORD xxx
MYSQL_PORT 0
MYSQL_DATABASE dbispconfig
MYSQL_USER_TABLE mail_user
MYSQL_CRYPT_PWFIELD password
#MYSQL_CLEAR_PWFIELD password
MYSQL_UID_FIELD uid
MYSQL_GID_FIELD gid
MYSQL_LOGIN_FIELD login
MYSQL_HOME_FIELD homedir
MYSQL_MAILDIR_FIELD maildir
#MYSQL_NAME_FIELD
MYSQL_QUOTA_FIELD quota
#MYSQL_QUOTA_FIELD concat(quota,'S')
#MYSQL_WHERE_CLAUSE access='y'
#MYSQL_AUXOPTIONS_FIELD concat('disableimap=',disableimap,',disablepop3=', disablepop3)
MYSQL_AUXOPTIONS_FIELD concat('disableimap=',if(disableimap='n','0','1'), ',disablepop3=',if(disablepop3='n','0','1'))

and restarted courier-authdaemon

But users with disable IMAP checked still can login through IMAP

Any help would be greatly appreciated.

Fredol
Reply With Quote