View Single Post
  #1  
Old 19th January 2012, 11:04
Steveorevo Steveorevo is offline
Member
 
Join Date: Feb 2010
Posts: 33
Thanks: 6
Thanked 6 Times in 5 Posts
Default Slave upgrade from 3.0.3.3 to 3.0.4.2 on Ubuntu

I followed the upgrade on my master as described at http://www.faqforge.com/linux/contro...e-ispconfig-3/ and everything went well. However, I have a slave that is hung with "Unable to connect to mysql server" it prompts for the master server hostname, password, dbispconfig database (which exists). I can telnet to the master on port 3306 and can see that MySQL connects, but alas the loop of "Unable to connect to mysql server" persists. I've verified the root password and can get to the master's MySQL with root via phpmyadmin. I've tried temporarily turning off the firewall on the master. Is there something else that could be causing this error message on the slave upgrade?

Help, clues appreciated!

*Update
I've checked the privileges table and appears OK. root has all privileges for dbispconfig, including the hostname of the master/slaves in MySQL. However, I just tried to connect via one MySQL Admin from the slave to the master and access in indeed denied for root@myslave.myhostname.com. Yet the slave is apart of the access table with all privileges. Curious.

Last edited by Steveorevo; 19th January 2012 at 11:34. Reason: Update
Reply With Quote
Sponsored Links