View Single Post
  #19  
Old 11th January 2012, 16:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,340 Times in 4,189 Posts
Default

This should not be nescessary as passing by reference is not required and ispconfig disables the warning automatically.

See /usr/local/ispconfig/interface/lib/app.inc.php Line 39:

@ini_set('error_reporting', E_ALL & ~E_NOTICE & ~E_DEPRECATED);

This works fine here with current PHP versions so my guess is that you have the ini_set function disabled in php.ini or something similar so that ISPConfig can not set the required error reporting level.

Either you enable ini_set in php.ini again so that ispconfig can set the error reporting level or you change the error_reporting in php.ini to:

error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

and restart apache2.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote