View Single Post
  #25  
Old 3rd January 2012, 21:57
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 387
Thanks: 28
Thanked 58 Times in 50 Posts
Default

This result seems to indicate that Hotmail / live.com is not blocking connections from your server. That is good.

I am sure you have searched for the error message that you posted, "SMTP, Port: 25, Yuva Hatası: 10060, Hata numarası: 0x800CCC0E", which almost certainly indicates that your ISP is tampering with traffic on port 25.

Edit /etc/postfix/main.cf and ensure that the TLS-related parameters looks similar to this:

Code:
# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
# This directive is deprecated in favor of the below.
#smtpd_use_tls = yes
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_tls_loglevel = 0
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
Next, edit /etc/postfix/master.cf and ensure that the services section of the file has the same lines as below un-commented; this enables email users to send and receive email over SSL:

Code:
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd
submission inet n       -       -       -       -       smtpd
#  -o smtpd_tls_security_level=encrypt
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
  -o milter_macro_daemon_name=ORIGINATING
smtps     inet  n       -       -       -       -       smtpd
  -o smtpd_tls_wrappermode=yes
  -o smtpd_sasl_auth_enable=yes
Don't forget to restart Postfix:

Code:
service postfix restart
Clients who wish to use STARTTLS should use the standard ports for POP3 (110), IMAP (143), and SMTP (25). Clients who wish to use SSL/TLS should use port 995 for POP3, port 993 for IMAP, and port 465 for SMTP.

Please try sending mail over port 465, with SSL enabled in your mail client, after making the above changes.

Last edited by cbj4074; 3rd January 2012 at 21:59. Reason: Forgot restarting Postfix step.
Reply With Quote