View Single Post
  #1  
Old 3rd January 2012, 08:41
ELY_M ELY_M is offline
Junior Member
 
Join Date: Jan 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Question postfix - not getting any emails. I can send out emails to outside from postfix

my server is on amazon aws service. I made sure smtpd ports are open.
I am able to use thunderbird to check my emails and send out emails.

I sent many test emails in my gmail and yahoo accounts to admin@my-domain.biz
They never show up in mailbox for user admin.
I do not see any errors in maillog

I have postfix 2.66 and dovecot installed

Code:
[root@ip-10-170-91-47 postfix]# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
html_directory = no
inet_interfaces = 10.170.91.47, localhost
inet_protocols = all
local_recipient_maps =
mail_spool_directory = /var/spool/mail
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain, mail.$mydomain
mydomain = my-domain.biz
myhostname = mail.my-domain.biz
mynetworks = 50.xx.xx.xx, 10.170.91.47, 127.0.0.0/8
mynetworks_style = host
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases.postfix
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
relay_domains =
sample_directory = /usr/share/doc/postfix-2.6.6/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP Authorized use only
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
unknown_local_recipient_reject_code = 550
[root@ip-10-170-91-47 postfix]#

dig command show that MX is set correctly...

Code:
dig MX my-domain.biz

; <<>> DiG 9.2.4 <<>> MX my-domain.biz
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40145
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 5

;; QUESTION SECTION:
;my-domain.biz.               IN      MX

;; ANSWER SECTION:
my-domain.biz.        3600    IN      MX      10 mail.my-domain.biz.

;; AUTHORITY SECTION:
my-domain.biz.        86400   IN      NS      ns1.afraid.org.
my-domain.biz.        86400   IN      NS      ns3.afraid.org.
my-domain.biz.        86400   IN      NS      ns2.afraid.org.
my-domain.biz.        86400   IN      NS      ns4.afraid.org.

;; ADDITIONAL SECTION:
mail.my-domain.biz.   3600    IN      A       50.xx.xx.xx
ns3.afraid.org.         390     IN      A       72.20.15.62
ns1.afraid.org.         390     IN      A       50.23.197.95
ns4.afraid.org.         48      IN      A       174.128.246.102
ns2.afraid.org.         6051    IN      A       174.37.196.55

;; Query time: 88 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Tue Jan  3 00:34:54 2012
;; MSG SIZE  rcvd: 216
I am able to telnet to mail server fine.
Code:
[glow@IBM ~]$ telnet mail.my-domain.biz 25557
Trying 50.xx.xx.xx...
Connected to mail.my-domain.biz (50.xx.xx.xx).
Escape character is '^]'.
220 mail.my-domain.biz ESMTP Authorized use only
EHLO localhost
250-mail.my-domain.biz
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
quit
221 2.0.0 Bye
Connection closed by foreign host.
[glow@IBM ~]$


I see no error in maillog
so I think emails get lost somewhere.....

Last edited by ELY_M; 3rd January 2012 at 09:04.
Reply With Quote
Sponsored Links