View Single Post
  #20  
Old 3rd January 2012, 01:46
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default

Next up, mail client configuration settings. (I wish I had seen that screenshot sooner, but that's okay.)

Have you tried any mail client other than Evolution, or tried from any location on the Internet other than your current location?

Many ISPs block outgoing traffic on port 25, so you'll never be able to send mail using that port. (The logic, while flawed, is that less SPAM will come from compromised PCs if they block port 25.)

Try using port 587 for your SMTP connection. (This is the same port you will use even with STARTTLS enabled.)

If you are using SSL for some reason (instead of STARTTLS), try port 465.
Reply With Quote