View Single Post
  #4  
Old 30th December 2011, 20:16
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 386
Thanks: 28
Thanked 58 Times in 50 Posts
Default

I understand the need to protect your privacy and scrub personal information from your posts, so we'll need to be clear as to when you're using "domain.com" literally and when you're using it as a generic placeholder.

In your most recent post, does the log literally say

Code:
postfix/smtpd[31014]: warning: IP: address not listed for hostname domain.com
or is your real domain name present (instead of domain.com)?

My setup works perfectly well, and while I use ISPConfig, I would think that your Postfix settings should not be all that different.

Here are my equivalent settings for the items that seem relevant:

Code:
myhostname = example.com
myorigin = /etc/mailname
mydestination = localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8 [::1]/128
Naturally, the following line will be different because I am using virtual mailboxes with MySQL, but it's worth posting (because yours looks unusually restrictive):

Code:
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
At this point, my questions are:

1.) Is your main.cf untouched? In other words, did you make any changes to it between the time Postfix was installed and this problem occurred?

2.) Did you insert the IP address 168.100.189.2/32, or was that done automatically during Postfix setup?

3.) What Linux distro are you using? Do you have the file /etc/mailname?

Last edited by cbj4074; 30th December 2011 at 20:23.
Reply With Quote