View Single Post
  #1  
Old 20th December 2011, 14:48
sgabor sgabor is offline
Junior Member
 
Join Date: Dec 2011
Location: Hungary/Budapest
Posts: 3
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via Skype™ to sgabor
Default MyDNS notify problem

Hi there,

I have a small but annoying problem, and I can't find any solution for this.
I have ISPConfig Version: 3.0.4.1 installed system with MyDNS (mydns (mydns) 1.2.8.31 (MySQL 5.1.41)) on Ubuntu 10.04 (32bit) - Linux neo.itcorp.hu 2.6.32-37-generic-pae #81-Ubuntu SMP Fri Dec 2 22:24:22 UTC 2011 i686 GNU/Linux.

The problem is when I setting up a new DNS domain in ISPconfig interface, that it generated without problem, but the secondary DNS system isn't notified, and also the new domain isn't created.
In the 2nd. system I tried to find the problem, but I can't find anything in the logs. It looks no package sent from main server to 2nd server.

I already enabled allow-update, allow-axfr, notify-enabled and notify-source options in /etc/mydns.conf.
For debugging I changed the log facility to logging to a file (/var/log/mydsn.log). In the log file I find these lines:
Quote:
mydns[737]: mydns: mydns 1.2.8.31 started Tue Dec 20 12:55:38 2011 (listening on 2 addresses)
mydns[739]: mydns: bind (UDP): 79.172.193.104:0 - Érvénytelen argumentum(22): Érvénytelen argumentum
mydns[739]: mydns: 79.172.193.104: SOA fiestasport.hu. (11) NEED_ANSWER, High Priority IO Driven Task: FORMERR in query - NOTIFY is currently not a supported opcode
mydns[739]: mydns: message from 64.85.160.91 not a query response or for wrong opcode: Siker
mydns[739]: last message repeated 22 times
Sorry for Hungarian words, I translated for you:
"Érvénytelen argumentum" means Invalid arguments
So I think the problem is
Quote:
mydns[739]: mydns: bind (UDP): 79.172.193.104:0 - Invalid arguments(22): Invalid arguments
but I don't know how to sole this.
In log entries the 64.85.160.91 address is the secondary server.

I tried to reinstall the mydns service and after reinstall updated the ISPconfig to reconfigure services, but no luck...

This system is a live system, and I installed about 1,5 years ago.

I attached the file with contain ipchains rules, mydns.conf.txt and mydns.log.txt.

Please help me to solve this problem.

Thanks a lot...

Gábor
Attached Files
File Type: txt iptables.txt (4.1 KB, 102 views)
File Type: txt mydns.conf.txt (2.4 KB, 115 views)
File Type: txt mydns.log.txt (13.1 KB, 92 views)
Reply With Quote
Sponsored Links