View Single Post
  #2  
Old 15th December 2011, 10:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,613 Times in 4,424 Posts
Default

These are all installation and configuration problems of your servers and no ISPConfig bugs, thats why nobody else reports them and why they are not listed in the bugtracker.

We would have been be able to help you if you post the 500 error messages.

1) Post the exact error.
2) Seems as if you uploaded the files with the wrong user or that you selected the wrong PHP mode for the website. Files ahve to be owned by the web user and client group, thats automatically the case when you upload them with FTP. If you upload them with ssh as root user, then you have to chown them afterwards. The website settings for PHP based cms systems have to be:

php mode: php-fcgi
Suexec: on

See Description in ISPConfig manual.

3) Thats a setting of the Linux distribution that you have choosen, not from ispconfig. Beside that, you should not use suphp for php based cms systems like joomla, wordpress, drupal etc. See 2) for the php settings that shpuld be used.

4) Post the exact error message from the error.log of the website.

Just a general note, the most stable and recommended distribution for ISPConfig is Debian. So for production systems you should use Debian or Ubuntu as recommended on ispconfig.org website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote