View Single Post
  #1  
Old 13th December 2011, 18:35
Bushytea Bushytea is offline
Junior Member
 
Join Date: Dec 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't Send Mail from Smart Phone or Outlook

Hi,

I am running a server with Centos 5.2, Postfix 2.3.3 and Dovecot. The server is not on my local network so it is not behind my router.

I can send mail to/from the email account on the server. (Ex: Send mail from server account to aol account then send mail from aol account back to server account)

I can even see the mail that is in the users mailbox from my phone but I am not able to send. When I try to setup the account in Outlook or try to send mail from my phone they both say they are unable to connect to the smtp server. When I test the settings in Outlook it says that it logs in successfully but cannot connect to the smtp server.I have searched and found tons of how-tos but just can not get it to work.

Here are a few different results I get when I telnet smtp.domain.com 25 and try to send an email.

Of Course the way I did it below does not work. I do receive the "Relay access denied" message.

Quote:
# telnet smtp.domain.com 25
Trying IP...
Connected to smtp.domain.com (IP).
Escape character is '^]'.
220 smtp.domain.com ESMTP Postfix
ehlo smtp.domain.com
250-smtp.domain.com
250-PIPELINING
250-SIZE 10240000
250-ETRN
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
mail from: user@domain.com
250 2.1.0 Ok
rcpt to: user@aol.com
554 5.7.1 <user@aol.com>: Relay access denied
Here is what I see in /var/log/maillog:

Quote:
Dec 13 11:25:31 postfix/smtpd[31014]: warning: IP: address not listed for hostname domain.com
Dec 13 11:25:31 postfix/smtpd[31014]: connect from unknown[IP]
Dec 13 11:25:47 postfix/smtpd[31014]: NOQUEUE: reject: RCPT from unknown[IP]: 554 5.7.1 <user@aol.com>: Relay access denied; from=<user@domain.com> to=<user@aol.com> proto=ESMTP helo=<smtp.domain.com>
Dec 13 11:25:50 postfix/smtpd[31014]: disconnect from unknown[IP]

Here is part of my main.cf from posfix:

Quote:
myhostname = mail.domain.com
mydomain = domain.com
myorigin = $mydomain
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, $mydomain
mynetworks = 127.0.0.0/8 168.100.189.2/32
alias_maps = hash:/etc/aliases
#
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination reject_invalid_hostname reject_non_fqdn_hostname reject_non_fqdn_sender reject_non_fqdn_recipient reject_unknown_sender_domain reject_unknown_recipient_domain reject_rbl_client zen.spamhaus.org permit
smtpd_helo_required = yes
disable_vrfy_command = yes
smtpd_delay_reject = no

# SASL Authentication
smtpd_sasl_auth_enable = yes
smtpd_sasl_type = dovecot
smtpd_sasl_path = /var/run/dovecot/auth-client
broken_sasl_auth_clients = yes
smtpd_sasl_security_options = noanonymous
Then here is my dovecot.conf

Quote:
protocols = imap pop3
listen = *
disable_plaintext_auth = no
pop3_uidl_format = %08Xu%08Xv
mechanisms = plain login
passdb pam {
args = /etc/pam.d/dovecot
}

client {
path = /var/run/dovecot/auth-client
mode = 0660
user = postfix
group = postfix
}
Thanks in advance
Reply With Quote
Sponsored Links