View Single Post
  #3  
Old 13th December 2011, 13:57
talkingnews talkingnews is offline
Member
 
Join Date: Jan 2011
Posts: 67
Thanks: 15
Thanked 6 Times in 6 Posts
Default

Quote:
Originally Posted by till View Post
I guess thats you have a problem with I/O Bandwidth or in other words, the harddisk speed is too slow. I've seen this problem several times with vps servers when too many vps are on the same host system. This can also affect mysql performance. I guess there is not much that you can do about this except of talking with your hosting provider.

What you can try to optimize mysql;

http://www.faqforge.com/linux/optimi...th-mysqltuner/

If your sites dont use innodb, then you should consider to switch innodb off in my.cnf file, so that mysql uses less memory.
As per my post above:

Quote:
Originally Posted by talkingnews View Post
I changed the theme to default, turned off all the plugins, changed all the mysql tables to to innodb and followed the recommendations of mysqltuner (even though, as I said, there's nothing about slow mysql in the logs I can see).
Quote:
Originally Posted by till View Post
Most likely they cache the results better.
Possibly, but here's the output from Zen Cart's diagnostics:

Code:
Database Data Size: 25,936 kB	Database Index Size: 6,496 kB
Parse Time: 0.119 - Number of Queries: 54 - Query Time: 0.008176764892578
So why would an old, non-optimized app manage to query a 26mb database and parse a complex page in 0.119s, while Wordpress admin takes 6-9 seconds to load a 2mb db?
Reply With Quote