View Single Post
  #15  
Old 13th December 2011, 00:26
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 388
Thanks: 28
Thanked 58 Times in 50 Posts
Default

After installing SquirrelMail myself and examining the Apache logs concerning the message that you now receive in the browser, "Forbidden: You don't have permission to access / on this server", I found the following:

Code:
[error] [client 184.74.75.65] client denied by server configuration: /usr/share/squirrelmailindex.php
[error] [client 184.74.75.65] client denied by server configuration: /usr/share/squirrelmailfavicon.ico
These messages indicate that the permission denial is happening at the Apache level (not the filesystem level), which is good. Also, your permissions on the /usr/share/squirrelmail directory are correct, so no need to change those. (As a side note, it is undesirable to change the default permissions on files/directories created via package installers. Doing so should always be a last resort.)

To allow access to that directory, it is necessary to add something similar to the following to your Apache configuration (ignore the first [Alias] line if you've already added that):

Code:
Alias / /usr/share/squirrelmail/
<Location />
Options +FollowSymLinks
order allow,deny
allow from all
</Location>
Once ISPConfig has written the change to disk, is the problem resolved?

Last edited by cbj4074; 13th December 2011 at 00:45.
Reply With Quote