View Single Post
  #1  
Old 11th December 2011, 19:25
Trunkles Trunkles is offline
Member
 
Join Date: Oct 2010
Location: New Zealand
Posts: 30
Thanks: 1
Thanked 3 Times in 2 Posts
Default webmail.server.example.com isn't there.

Hi folks.

I've made the mods suggested so that http://webmail.drsimon.co.nz should give a squirrel mail login, but it doesn't.

What I get is the standard
Code:
It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.
If, however, you go to http://drsimon.co.nz/webmail all is fine.

Here's my /etc/apache2/conf.d/squirrelmail.conf
Code:
Alias /squirrelmail /usr/share/squirrelmail
Alias /webmail /usr/share/squirrelmail

<Directory /usr/share/squirrelmail>
  Options FollowSymLinks
  <IfModule mod_php5.c>
    AddType application/x-httpd-php .php
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_admin_flag allow_url_fopen Off
    php_value include_path .
    php_admin_value upload_tmp_dir /var/lib/squirrelmail/tmp
    php_admin_value open_basedir /usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname
    php_flag register_globals off
  </IfModule>
  <IfModule mod_dir.c>
    DirectoryIndex index.php
  </IfModule>

  # access to configtest is limited by default to prevent information leak
  <Files configtest.php>
    order deny,allow
    deny from all
    allow from 127.0.0.1
  </Files>
</Directory>

# users will prefer a simple URL like http://webmail.example.com
<VirtualHost 222.154.250.78>
  DocumentRoot /usr/share/squirrelmail
  ServerName webmail.drsimon.co.nz
</VirtualHost>

# redirect to https when available (thanks omen@descolada.dartmouth.edu)
#
#  Note: There are multiple ways to do this, and which one is suitable for
#  your site's configuration depends. Consult the apache documentation if
#  you're unsure, as this example might not work everywhere.
#
#<IfModule mod_rewrite.c>
#  <IfModule mod_ssl.c>
#    <Location /squirrelmail>
#      RewriteEngine on
#      RewriteCond %{HTTPS} !^on$ [NC]
#      RewriteRule . https://%{HTTP_HOST}%{REQUEST_URI}  [L]
#    </Location>
#  </IfModule>
#</IfModule>
I've obviously done something wrong somewhere but I've no idea what. I bet you have though!

Enlighten me, please.

Simon.
Reply With Quote
Sponsored Links