View Single Post
  #3  
Old 10th December 2011, 17:58
talkingnews talkingnews is offline
Member
 
Join Date: Jan 2011
Posts: 67
Thanks: 15
Thanked 6 Times in 6 Posts
Default

Thanks Falko! OK, here we go:

Perfectly working site - runs like a dream:
http://pastebin.com/Y3q6wQb8

NON working site on same server which shows 404 for all php scripts:
http://pastebin.com/KeEUAEru
Again, I've double, triple checked user and dir owner and perms on those files.
Plain text files work just fine.

Incidentally, when I turn off "use own error documents" I get "no input file specified" for the php file which I know exists.

When I turn them back on, I get "404 not found" for that file.

Also, the wordpress example section of nginx says it requires cgi.fix_pathinfo = 0 - althugh it seems to make no difference, and even a plain old phpinfo.php file in the root dir fails. And yet on the other site, on the same server, all is good. But is that cgi.fix_pathinfo = 0 going to give me problems if I put it in?

EDIT: Another long night poring through the logs - this looks a bit odd to me.. why am I seeing random and occasional entries from other sites on my ISPC?
The log below belongs to web9, btw..

This log entry is from a site that doesn't work, but does at least match the site AND web number

2011/12/10 16:19:18 [error] 29469#0: *2745 open() "/var/www/web9.co.uk/web/files/Package.pdf" failed (2: No such file or directory), client: 66.249.72.x, server: web9.co.uk, request: "GET /files/Diamond.pdf HTTP/1.1", host: "web9.co.uk"

The next one is from a WORKING site, but a completely different user:

2011/12/10 08:22:13 [error] 17201#0: *47071 open() "/var/www/web9.co.uk/web/forum/images/Logo.gif" failed (2: No such file or directory), client: 66.249.72.x, server: web9.co.uk, request: "GET /forum/images/Logo.gif HTTP/1.1", host: "web1.co.uk"

Next up, an entry from a NON working site:

2011/12/10 22:04:55 [error] 29471#0: *22753 open() "/var/www/web9.co.uk/web/mp3/10-12-11.mp3" failed (2: No such file or directory), client: 84.93.146.x, server: web9.co.uk, request: "GET /mp3/10-12-11.mp3 HTTP/1.1", host: "www.web12.co.uk"

Here's what /var/www looks like

Code:
drwxr-xr-x  5 root    root     4096 2011-12-07 05:20 .
drwxr-xr-x 15 root    root     4096 2011-12-09 00:32 ..
drwxr-xr-x  2 ispapps ispapps  4096 2011-11-27 19:57 apps
lrwxrwxrwx  1 root    root       30 2011-12-06 14:15 web9.co.uk -> /var/www/clients/client3/web9/
drwxr-xr-x  7 root    root     4096 2011-12-06 11:30 clients
lrwxrwxrwx  1 root    root       30 2011-12-02 13:13 web3.co.uk -> /var/www/clients/client3/web3/
-rw-r--r--  1 root    root     1985 2011-11-25 17:40 index.html
-rw-r--r--  1 root    root    13177 2011-11-27 17:05 ispconfig_install.log
lrwxrwxrwx  1 root    root       30 2011-12-06 11:30 web5.co.uk -> /var/www/clients/client4/web5/
lrwxrwxrwx  1 root    root       30 2011-11-27 17:14 web1.co.uk -> /var/www/clients/client0/web1/
lrwxrwxrwx  1 root    root       31 2011-12-07 05:20 web12.co.uk -> /var/www/clients/client2/web12/
lrwxrwxrwx  1 root    root       31 2011-12-07 05:17 web11.co.uk -> /var/www/clients/client2/web11/
drwxr-xr-x  2 root    root     4096 2011-11-26 20:09 webalizer
And here's a failed request from one of the non-working sites when I turn debug_http on:

Code:
2011/12/11 09:48:43 [debug] 4310#0: *9 http upstream dummy handler
2011/12/11 09:48:43 [debug] 4310#0: *9 http run request: "/index.php?"
2011/12/11 09:48:43 [debug] 4310#0: *9 http upstream check client, write event:1, "/index.php"
2011/12/11 09:48:43 [debug] 4310#0: *9 http upstream recv(): -1 (11: Resource temporarily unavailable)
2011/12/11 09:48:43 [debug] 4310#0: *9 http upstream request: "/index.php?"
2011/12/11 09:48:43 [debug] 4310#0: *9 http upstream dummy handler
2011/12/11 09:48:43 [debug] 4310#0: *9 http upstream request: "/index.php?"
But if I look in php5-fpm.log, it there's nothing since I restarted it 2 days ago:

Code:
[09-Dec-2011 15:32:18] NOTICE: fpm is running, pid 17036
[09-Dec-2011 15:32:18] NOTICE: ready to handle connections
Confused!

Last edited by talkingnews; 11th December 2011 at 11:58. Reason: More info
Reply With Quote