View Single Post
  #7  
Old 4th December 2011, 17:05
Sander72 Sander72 is offline
Junior Member
 
Join Date: Dec 2011
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem on my Debian lenny setup with ISPCONFIG 3.0.4.1. At my system mod_dav is running as "www-data" which doesn't match with my webdav-permissions according to the configuration of ISPCONFIG. This is noticed before.
See below:

http://www.howtoforge.com/using-webd...n-ubuntu-9.10:
Because mod_dav is running with the privileges of the Apache user and group (both www-data on Ubuntu), we must change the owner and group of the /var/www/clients/client1/web1/web to www-data recursively (otherwise you won't be allowed to create/edit/delete files/directories using WebDAV):

If I change the owner and group to www-data, everything runs fine. But I think from version 3.03 this is not the way it should be. Has someone ideas?

See below for more information on my setup:
# add support for apache mpm_itk
<IfModule mpm_itk_module>
AssignUserId web45 client1
</IfModule>

<IfModule mod_dav_fs.c>
# Do not execute PHP files in webdav directory
<Directory /var/www/clients/client0/web45/webdav>
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
</Directory>
# DO NOT REMOVE THE COMMENTS!
# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
# WEBDAV BEGIN

Alias /webdav/test1 /var/www/clients/client0/web45/webdav/test1
<Location /webdav/test1>
DAV On
AuthType Digest
AuthName "test1"
AuthUserFile /var/www/clients/client0/web45/webdav/test1.htdigest
Require valid-user
Options +Indexes
Order allow,deny
Allow from all
</Location>
# WEBDAV END
</IfModule>
Reply With Quote