View Single Post
  #1  
Old 29th November 2011, 17:59
DiscipleGeek DiscipleGeek is offline
Junior Member
 
Join Date: Aug 2011
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Default ISPConfig no longer runs: 500 Internal Server error & mod_fcgid: error reading data

I've been running ISPConfig on CentOS 5.7 Final in an Amazon EC2 instance for several weeks with no problems with ISPConfig itself.

Our server had been hitting its max in RAM and chugging out the sites, but we discovered that it's because Amazon's EC2 does not come preinstalled with swap. I got swap running and now all my sites are running fine... except ISPConfig.

Now, when I go to the ISPConfig control panel, I get a 500 internal server error. The only logs that show anything are the apache error_log:

Code:
[Tue Nov 29 09:31:46 2011] [warn] [client 97.67.115.165] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Tue Nov 29 09:31:46 2011] [error] [client 97.67.115.165] Premature end of script headers: index.php
In an attempt to locate and resolve the issue myself, I searched the boards and found a couple of threads that seemed like they might have something to do with my issue:


http://www.howtoforge.com/forums/sho...FastCGI+server

Unfortunately, while the issue is close, the solutions don't really fit my server, especially since the php script is ispconfig itself.

And finally here:

http://www.howtoforge.com/forums/sho...FastCGI+server

Which suggested that I run the update for ISPConfig. I did this with no change in status.

Please help?
Reply With Quote
Sponsored Links