View Single Post
  #9  
Old 28th November 2011, 20:39
talkingnews talkingnews is offline
Member
 
Join Date: Jan 2011
Posts: 67
Thanks: 15
Thanked 6 Times in 6 Posts
Default

I'm using the current, stable version of nginx - 1.0.10.

Unfortunately, as I posted in this thread, the version that the standard repo wants to install is horribly old - something like 1.0.3 from way back in May IIRC.

Same went for php, so I had to add

Code:
deb http://nginx.org/packages/ubuntu/ lucid nginx
deb-src http://nginx.org/packages/ubuntu/ lucid nginx

deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all
Then I could get the current stable versions of php-fpm and nginx.

I couldn't see anything about having to use old versions of Nginx - all the instructions said was that:

Quote:
"If you want to use nginx instead of Apache with ISPConfig, please note that your nginx version must be at least 0.8.21, and you must install PHP-FPM as well. For CGI/Perl support, you must use fcgiwrap. This is all covered by this tutorial".
Now, of course, a lot of work went into ISPC and I'm very grateful, but mention in the docs of not being able to use the current stable release of nginx might have saved some time for us both

So, bearing in mind the application I'm writing REQUIRES features of the current stable version*, is there any way we can get round this now?

I'm happy to head over to the Nginx forums and ask there - but what should I be asking? Where do you think the problem is coming in? Should I file this as a bug in the ISPC bug tracker?

*(In case anyone is wondering: I need the http_mp4_module introduced in 1.0.7, more importantly the bugfix for it in 1.0.10, and "decrease of memory consumption if SSL is used" from 1.0.9).
Reply With Quote