View Single Post
  #1  
Old 13th November 2011, 00:33
MetZ MetZ is offline
Junior Member
 
Join Date: Aug 2011
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Moving to nginx failing

Hi..
I am struggling with ISPconfig latest and moving to nginx.

I have even tried to completely re-install my server, before installing ispconfig
http://www.howtoforge.com/perfect-se...ispconfig-3-p7

It looks like ISPconfig does not start, I can not find it in my processes list. I tried to do an update on it, and it spits out a couple of error messages:
Code:
Configuring Apps vhost
PHP Warning:  symlink(): No such file or directory in /tmp/ispconfig3_install/install/lib/installer_base.lib.php on line 1515
Configuring Database
Configuring Bastille Firewall
Updating ISPConfig
PHP Notice:  Undefined property: installer::$ispconfig_interface_installed in /tmp/ispconfig3_install/install/update.php on line 333
Reconfigure Crontab? (yes,no) [yes]:
When doing a fresh-install, some symlink error appeared (I have tried 3-4 times now, almost giving up and going back to apache2).

Any suggestions? any logs I can check? Try to load ispconfig manually?

Thanks for any help!
-Tom

EDIT:
After more research on this, I have figured more out. I think it has something to do with nginx. Now I receive a 403 Forbidden message when domain.com:8080
If I go to domain.com (phpinfo in index.php), the phpinfo display with FPM/FastCGI as server API.
I have tried to look at the ispconfig.vhost file, but as I am totally new to nginx, I am not sure where to start. it is the default vhost file installed with installer.
Any suggestions?

Last edited by MetZ; 13th November 2011 at 01:46.
Reply With Quote
Sponsored Links