View Single Post
  #12  
Old 11th November 2011, 21:12
Tastiger Tastiger is offline
Junior Member
 
Join Date: Feb 2011
Posts: 28
Thanks: 3
Thanked 1 Time in 1 Post
Default

Quote:
Looks ok. Did you restart Apache? If that didn't work, can you post the polyfidelity.org.au vhost configuration?
/etc/apache2/sites-enabled/900-polyfidelity.org.au.vhost

Code:
<Directory /var/www/polyfidelity.org.au>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
    DocumentRoot /var/www/clients/client0/web32/web

    ServerName polyfidelity.org.au
    ServerAlias *.polyfidelity.org.au
    ServerAlias bendigo.polyfidelity.org.au
    ServerAlias www.polyfidelity.org.au
    ServerAdmin webmaster@polyfidelity.org.au

    ErrorLog /var/log/ispconfig/httpd/polyfidelity.org.au/error.log


    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 502 /error/502.html
    ErrorDocument 503 /error/503.html

    <IfModule mod_ssl.c>
    </IfModule>
    <Directory /var/www/polyfidelity.org.au/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all

        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes
    </Directory>
    <Directory /var/www/clients/client0/web32/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all

        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes
    </Directory>

    <IfModule mod_ruby.c>
      <Directory /var/www/clients/client0/web32/web>
        Options +ExecCGI
      </Directory>
      RubyRequire apache/ruby-run
      #RubySafeLevel 0
      <Files *.rb>
        SetHandler ruby-object
        RubyHandler Apache::RubyRun.instance
      </Files>
      <Files *.rbx>
        SetHandler ruby-object
        RubyHandler Apache::RubyRun.instance
      </Files>
    </IfModule>


    # cgi enabled
	<Directory /var/www/clients/client0/web32/cgi-bin>
      Order allow,deny
      Allow from all
    </Directory>
    ScriptAlias  /cgi-bin/ /var/www/clients/client0/web32/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # suexec enabled
    SuexecUserGroup web32 client0
    # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
    </FilesMatch>
    # suphp enabled
    <Directory /var/www/clients/client0/web32/web>
		<IfModule mod_suphp.c>
        suPHP_Engine on
        # suPHP_UserGroup web32 client0
        AddHandler x-httpd-suphp .php .php3 .php4 .php5
        suPHP_AddHandler x-httpd-suphp
		</IfModule>
    </Directory>

    RewriteEngine on
    RewriteCond %{HTTP_HOST}   ^bendigo.polyfidelity.org.au$ [NC]
    RewriteRule   ^/(.*)$ /bendigo/$1  [L]

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
      AssignUserId web32 client0
    </IfModule>

    <IfModule mod_dav_fs.c>
	  # Do not execute PHP files in webdav directory
      <Directory /var/www/clients/client0/web32/webdav>
	    <FilesMatch "\.ph(p3?|tml)$">
          SetHandler None
        </FilesMatch>
      </Directory>
      # DO NOT REMOVE THE COMMENTS!
      # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
      # WEBDAV BEGIN
      # WEBDAV END
    </IfModule>


</VirtualHost>
Reply With Quote