View Single Post
  #1  
Old 6th November 2011, 09:47
blainarm387 blainarm387 is offline
Junior Member
 
Join Date: Nov 2011
Posts: 6
Thanks: 3
Thanked 0 Times in 0 Posts
Question Problems with sending and receiving mail on CentOS

Hello there.

I'm a first-time poster to this site, and I will gladly admit I'm a newbie when it comes to linux and configuring sites. I've done quite a bit of programming in PHP and Javascript, so I'm not completely clueless, but I have to confess to being a bit short on knowledge when it comes to configuring a server.

I have a VPS with a Japanese hosting company, and they provide users with a standard installation using Cent OS 5.5. I went through the guide at http://bit.ly/aRRadF in order to configure it.

For the most part, everything works just fine, though I decided to keep phpmyadmin as using cookies for authentication. However, I can't for the life of me get the mail server to work. I tried setting up Mozilla Thunderbird, but it says that it can't find the settings for my email account.

So next, I tried using Squirrelmail. At first, it told me that it could not connect to the IMAP server. Logging in with a bad username/password combination told me that the login had failed, so I knew that it was working. After poking around a bit, I found that if you don't have a Maildir directory in the user's home directory, Squirrelmail won't work. I put one in, and it let me log in.

But then, we have another problem. Sending mail to anyone other than myself doesn't work. The program doesn't give me any errors, but the mails don't get through. Sending mails from other accounts doesn't work either. A couple of days ago, I sent some test mails, and now, two days later, I'm getting error messages from Mailer-Daemon saying that the server refused all attempts to connect.

Also--and here's the weird thing--when I send a mail to myself via Squirrelmail, it won't show up in my inbox. But then when I log in to my server via SSH and type mail, it shows up fine. But it then tells me that the mail is in the directory /var/spool/mail/[my username].

Connecting to my IMAP server via Telnet seems to work, though I have no clue what to do from there.

I really have no clue as to what is going on here. I have tried doing searches to find the answer for myself, but I really don't know what questions to ask.

That's why I'm here.

Anyway, if anyone can help me I'd really appreciate it.

Warmest regards,

Blain Armstrong
Chiba, Japan
Reply With Quote
Sponsored Links