View Single Post
  #1  
Old 5th November 2011, 17:07
cyprus cyprus is offline
Member
 
Join Date: Oct 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Question Nginx doesnīt restart after installation of ISPConfig 3

Okay here I am the last 3 days I was setting up a server from scratch with one focus getting ISPConfig running.

I used debian with bind & courier nginx as serversoftware thttpd for cgi implemented fastcgi and squirrelmail and walked a long way.
Everything worked fine and then I installed ISPConfig.
In the first moment everything seems to be okay. But I couldnīt call my server via browser got a "bad gateway".
I tried to restart nginx and got this:
Quote:
root@v10300122146:~# /etc/init.d/nginx restart
Restarting nginx: nginx: [emerg] SSL_CTX_use_certificate_chain_file("/etc/nginx/cert.pem") failed (SSL: error:02001002:system library:fopen:No such file or directory error:20074002:BIO routines:FILE_CTRL:system lib error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib)
nginx: configuration file /etc/nginx/nginx.conf test failed
It looks like an SSL problem but there arenīt any *.pem files in my nginx folder. And I ainīt got no idea how to fix it.

Thanx for every hint

Cyprus
Reply With Quote
Sponsored Links