View Single Post
  #1  
Old 28th October 2011, 07:52
Machtyn Machtyn is offline
Junior Member
 
Join Date: Oct 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default postfix can't find user

I followed the guide here: Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (CentOS 6.0 x86_64) and everything seems to be working properly.

I set up an account admin at jawlawky.com

I sent a test email using mailx and then attempted to login. Unfortunately, everytime I try to login using either the raw telnet connection or the SquirrelMail web access, I have trouble. Finding that the imap was having trouble changing directory (chdir admin/admin/: No such file or directory) and knowing that the server is supposed to create the directory, I check my /var/log/maillog file. What I see is (with the timestamp and servername removed):
Code:
clamd[27102]: SelfCheck: Database status OK.
postfix/pickup[3196]: 7496138C8: uid=0 from=<root>
postfix/cleanup[3220]: 7496138C8: message-id=<20111028033047.7496138C8@alvinadams.jawlawky.com>
postfix/qmgr[27200]: 7496138C8: from=<root@alvinadams.jawlawky.com>, size=450, nrcpt=1 (queue active)
postfix/smtpd[3231]: connect from unknown[127.0.0.1]
postfix/smtpd[3231]: 4721B38CB: client=unknown[127.0.0.1]
postfix/cleanup[3220]: 4721B38CB: message-id=<20111028033047.7496138C8@alvinadams.jawlawky.com>
postfix/qmgr[27200]: 4721B38CB: from=<root@alvinadams.jawlawky.com>, size=898, nrcpt=1 (queue active)
amavis[32378]: (32378-01) Passed CLEAN, <root@alvinadams.jawlawky.com> -> <admin@jawlawky.com>, Message-ID: <20111028033047.7496138C8@alvinadams.jawlawky.com>, mail_id: SUT6LVtW2Fdb, Hits: 0.799, size: 450, queued_as: 4721B38CB, 5814 ms
postfix/smtp[3224]: 7496138C8: to=<admin@jawlawky.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=5.9, delays=0.03/0/0.01/5.8, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=32378-01, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 4721B38CB)
postfix/qmgr[27200]: 7496138C8: removed
postfix/virtual[3238]: 4721B38CB: to=<admin@jawlawky.com>, relay=virtual, delay=0.04, delays=0.01/0.02/0/0.01, dsn=5.1.1, status=bounced (unknown user: "admin@jawlawky.com")
postfix/cleanup[3220]: 50BC438CC: message-id=<20111028033053.50BC438CC@alvinadams.jawlawky.com>
postfix/qmgr[27200]: 50BC438CC: from=<>, size=2846, nrcpt=1 (queue active)
postfix/bounce[3240]: 4721B38CB: sender non-delivery notification: 50BC438CC
postfix/qmgr[27200]: 4721B38CB: removed
postfix/cleanup[3220]: 5444138C8: message-id=<20111028033053.50BC438CC@alvinadams.jawlawky.com>
postfix/qmgr[27200]: 5444138C8: from=<>, size=2992, nrcpt=1 (queue active)
postfix/local[3242]: 50BC438CC: to=<root@alvinadams.jawlawky.com>, relay=local, delay=0.02, delays=0.01/0.01/0/0.01, dsn=2.0.0, status=sent (forwarded as 5444138C8)
postfix/qmgr[27200]: 50BC438CC: removed
postfix/virtual[3238]: 5444138C8: to=<admin@jawlawky.com>, orig_to=<root@alvinadams.jawlawky.com>, relay=virtual, delay=0.01, delays=0.01/0/0/0.01, dsn=5.1.1, status=bounced (unknown user: "admin@jawlawky.com")
postfix/qmgr[27200]: 5444138C8: removed
Okay, so I've got something wrong with my database entries (I think). Oh, by the way, the FQDN is alvinadams.jawlawky.com - if that's important.

Here are my entries:
Code:
mysql> SELECT email, quota FROM users;
+-------+--------+
| email | quota  |
+-------+--------+
| admin | 262144 |
+-------+--------+
1 row in set (0.00 sec)

mysql> SELECT * FROM domains;
+--------------+
| domain       |
+--------------+
| jawlawky.com |
+--------------+
1 row in set (0.00 sec)
What am I missing? What else do I need to check? Does there happen to be a connection error with a component?

Thank you very much.

Last edited by Machtyn; 28th October 2011 at 07:58.
Reply With Quote
Sponsored Links