View Single Post
  #1  
Old 7th September 2011, 10:08
zenny zenny is offline
Senior Member
 
Join Date: Nov 2006
Posts: 176
Thanks: 20
Thanked 6 Times in 6 Posts
Question [SOLVED]: SMTP Server Offline

I have updated Centos 5.6 (updated with some perl-Compress-Raw-Bzip2 and perl-Compress-Raw-Zlib errors, but solved by downgrading and upgrading as stated http://www.centos.org/modules/newbb/...25120&forum=37 and reinstalled all dependencies including amavisd-new and spamassasin and all other 5 dependencies). I still have ISPConfig 3.0.2.2.

It was a running ISPConfig server but went amok after CentOS update. with the SMTP Server always offline. So far, I tried:

1) /etc/init.d/postfix restart
(gives not error, but dies after a few seconds)

2) The last 20 lines of maillog (tail -n 20 /var/log/maillog) shows this line repeatedly:

Sep 7 09:56:35 server1 amavis[6165]: (!)Net::Server: 2011/09/07-09:56:35 Couldn't open lock file "/var/amavis/amavisd.lock"[Permission denied]\n at line 203 in file /usr/lib/perl5/vendor_perl/5.8.8/Net/Server/PreForkSimple.pm

3) I checked with postfix -d | grep mynetworks which results:

mynetworks = 127.0.0.0/8 PUBLIC_IP_1/30 PUBLIC_IP_2/32
mynetworks_style = subnet
parent_domain_matches_subdomains = debug_peer_list,fast_flush_domains,mynetworks,perm it_mx_backup_networks,qmqpd_authorized_clients,rel ay_domains,smtpd_access_maps
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks
smtpd_client_event_limit_exceptions = ${smtpd_client_connection_limit_exceptions:$mynetw orks}
smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination

4) I cheked with 'postfix -n | grep mynetworks' which results:

mynetworks = 127.0.0.0/8 [::1]/128
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination

Could not figure out where did I go wrong? Thanks in advance for any inputs.

/zenny

Last edited by zenny; 8th September 2011 at 09:48. Reason: solved
Reply With Quote
Sponsored Links