View Single Post
  #8  
Old 18th August 2011, 06:02
rgordey rgordey is offline
Junior Member
 
Join Date: Aug 2011
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by www View Post
I had the same problem. Commenting out
Code:
LocalSocket unix:/var/run/clamav/clamd.sock
and
Code:
FixStaleSocket yes
in /etc/clamd.conf allowed clamd to restart.

Then I noticed that there was a new version of clamd available through yum. Installing that seems to have fixed the problem and clamd now restarts even with the lines above uncommented.
I don't want to be a wet blanket, but you haven't fixed the problem, you've ignored it. What you did was to turn off the socket by which 99% of local programs will submit data to be scanned for viruses by clamav. To be perfectly honest, while it is possible to configure clamav to accept submissions via tcp that's not too popular right now.

Clamav was complaining that either /var/run/clamd/clamd.sock (the bolded directory) didn't exist or it had no rights to read/create/modify etc. in that directory.

Solution:
#mkdir /var/run/clamd
#chown root:<same group name that clamd runs as> /var/run/clamd

You also might want to un-comment those two lines in clamd.conf.
Reply With Quote