View Single Post
  #4  
Old 17th August 2011, 13:34
alleks alleks is offline
Senior Member
 
Join Date: Nov 2010
Posts: 157
Thanks: 9
Thanked 9 Times in 9 Posts
Default

Sorry for the delay. I've fixed it, and here is the explication of it

When I was trying to connect to mysql with the -h parameter set to 127.0.0.1
Code:
mysql -u ispconfig  -pHAHA -h 127.0.0.1
I was getting an error that I was not allowed to do so, but if I when I was setting the parameter -h to localhost everything was ok.

Then I tried modifying all the files that were connecting to mysql for postfix and had the value hostname set to 127.0.0.1 to localhost but still no success.

After a while watching logs, searching on the interned I went to phpmyadmin and do some checking there and I noticed that ISPConfig's databases had the permissions set for user ispconfig on host localhost so what I did was to add the same use but with the host set to 127.0.0.1.

That is weird, because 127.0.0.1 and localhost by default should resolv the same thing. I don't know why was that happening but I have fixed the way I just told you.

Good luck if any1 else has this problem.
Reply With Quote