View Single Post
  #3  
Old 15th August 2011, 23:24
MetZ MetZ is offline
Junior Member
 
Join Date: Aug 2011
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi..

Thanks for your reply ;p

I have been trying to sort out this myself.. and I have solved it.

Logged in and su - to get root access

1: Moved cake to: /usr/share/cakephp/cake
2: Moved vendors to: /usr/share/cakephp/vendors
3: Checked ownership of vendors & cake + sub-files (ls -all = root:root)
5: added /usr/share/cakephp to the Options :: PHP open_basedir in ISPConfig
6: Saved website

7: Edited app/webroot/index.php
Code:
if (!defined('CAKE_CORE_INCLUDE_PATH')) {
	define('CAKE_CORE_INCLUDE_PATH', DS.'usr'.DS.'share'.DS.'cakephp');
}
And voila, it is working.. two separate domains/apps, using same cake core. Perfect.

Hope this can help anyone else

Edit: Using Fastcgi + suexec. Tried with suPHP also,, working just fine.
Edit2: The problem from first post and the setup not working, was that my app/webroot/index.php was checking for a "cake" dir and not the cake_1_3_6, further down in config. Also, I did not realize that "vendors" also was needed!

-Tom

Last edited by MetZ; 15th August 2011 at 23:26.
Reply With Quote