View Single Post
  #7  
Old 14th August 2011, 02:13
MetZ MetZ is offline
Junior Member
 
Join Date: Aug 2011
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Now.. Something strange happened...

I was adding everything trough admin account, and no rewrite was working at all.

After my last reply in this thread I thougth, what if I delete the domain/site trough ispconfig, and add a reseller, and add the domain/site trough that reseller account.

I created a reseller account, logged in, created a new client + domain/site.
Tried the rewrite script, exactly same error (however, I noticed a "client0" had appeard in /var/www/clients/.

OK, I thought, and just deleted everything again, logged in to phpmyadmin as root, and edited all the db tables for ispconfig "auto-increment" values, to set next site/domain/ftp/db id to the next value (I like my dbs to be clean you can say). Then I went ahead again, as admin, and re-added the website, and ftp account. Uploaded the rewrite.php + htaccess file, and, wtf, it works!?!

Now rewrite.php are working as it should.. and the only thing I did was to create and delete a reseller + client/website on that reseller account.

The client0 are still located in my /var/www/clients/client0, it is an empty folder. Could this have something to do with it?

Strange!!

Edit: Had another domain on my server where rewrite was not working, just tested with the same script, and rewrite works there as well (did nothing to that domain/site/client - except uploading the rewrite.php + htaccess after it suddenly worked on the other domain).

-Tom

Last edited by MetZ; 14th August 2011 at 02:17.
Reply With Quote