View Single Post
  #1  
Old 5th August 2011, 05:17
Salital Salital is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 5
Thanked 0 Times in 0 Posts
Default Local Website Url - 403 Forbidden

Hi Guys,

I'm a newbie about knowledge of Ispconfig and how to configure it and I'm tryng to understand about DNS, Redirect, Cname MX Record and all about a webserver configuration. I'm searching on the forum but don't find an answer to my question for this reason I hope you can help me to figure out my troubles

But my question is maybe simple for a Member Senior of this community or for everybody else that know much more than about Ispconfig

MY QUESTION

When I go on the local URL of the the website that I create but It doesn't work

http://192.168.1.106/clients/client1/web1/web

I tryed also

http://192.168.1.106/mywebsite.com/web

and it doesn't work too

I installed the Ispconfig 3 on the last Perfect Server Debian Squeez (3.0.3) on my home webserver when I digit the local URL of the Ispconfig http://192.168.1.106:8080 everything go ok and I can access like Admin

1. I Create a User

On the CLient Tab create the Client: ciao

2. I Create a Website

I create a website I wish run a Ruby or a Ruby On Rails Website but now nevermind if now it doesn't work I want view in the website a simple .html file to understand that it works

Server: server1.mywebsite.com
Client: ciao
IP-Address: *
Domain: mywebsite.com
Harddisk Quota MB: 100 MB
Traffic Quota MB: -1
CGI: NO CHECKED
SSI: NO CHECKED
Ruby: CHECKED
SuEXEC: NO CHECKED
Own Error-Documents: CHECKED
Auto-Subdomain: www.
SSL: NO CHECKED
PHP: Disabled
Active: CHECKED


OTHER INFORMATIONS

in the /etc/apache2/sites-enabled directory I have 5 files

000-apps.vhost -> /etc/apache2/sites-available/apps.vhost
000-default -> ../sites-available/default
000-ispconfig.conf -> /etc/apache2/sites-available/ispconfig.conf
000-ispconfig.vhost -> /etc/apache2/sites-available/ispconfig.vhost
mywebsite.com.vhost -> /etc/apache2/sites-available/mywebsite.com.vhost

the last file inside mywebsite.com.vhost have the follow quote maybe is important to know

Quote:

<Directory /var/www/mywebsite.com>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /var/www/mywebsite.com/web

ServerName mywebsite.com
ServerAlias www.mywebsite.com
ServerAdmin webmaster@mywebsite.com

ErrorLog /var/log/ispconfig/httpd/mywebsite.com/error.log


ErrorDocument 400 /error/400.html
ErrorDocument 401 /error/401.html
ErrorDocument 403 /error/403.html
ErrorDocument 404 /error/404.html
ErrorDocument 405 /error/405.html
ErrorDocument 500 /error/500.html
ErrorDocument 503 /error/503.html

<Directory /var/www/mywebsite.com/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
<Files ~ '.php[s3-6]{0,1}$'>
Order allow,deny
Deny from all
Allow from none
</Files>
</Directory>
<Directory /var/www/clients/client1/web1/web>
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
<Files ~ '.php[s3-6]{0,1}$'>
Order allow,deny
Deny from all
Allow from none
</Files>
</Directory>

<IfModule mod_ruby.c>
<Directory /var/www/clients/client1/web1/web>
Options +ExecCGI
</Directory>
RubyRequire apache/ruby-run
#RubySafeLevel 0
<Files *.rb>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
<Files *.rbx>
SetHandler ruby-object
RubyHandler Apache::RubyRun.instance
</Files>
</IfModule>

# Clear PHP settings of this website
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>

# add support for apache mpm_itk
<IfModule mpm_itk_module>
AssignUserId web1 client1
</IfModule>

<IfModule mod_dav_fs.c>
# DO NOT REMOVE THE COMMENTS!
# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
# WEBDAV BEGIN
# WEBDAV END
</IfModule>

<Directory /var/www/mywebsite.com/web>
AllowOverride All
</Directory>
</VirtualHost>
TIP:on the MONITOR Tab on the Admin Ispconfig Panel I read

Status of Services (Server : server1.mywebsite.com)

Data from: 2011-08-04 17:40

Web-Server: Offline
FTP-Server: Offline
SMTP-Server: Offline
POP3-Server: Offline
IMAP-Server: Offline
DNS-Server: Offline
mySQL-Server: Offline

maybe this could be useful to understand why it doesn't work

bye & thanks

S
Reply With Quote
Sponsored Links