View Single Post
  #1  
Old 11th July 2011, 15:46
jasondavis87 jasondavis87 is offline
Junior Member
 
Join Date: Jul 2011
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Default all subdomains work except www

Hello all,

I've searched the forums but didn't find anything on this:

My issue is that I have a website: domain.com
In my website i need all subdomains to goto the same place. I have a php file that parses the subdomain out and displays different data. So for example, example1.domain.com, example2.domain.com, example3.domain.com need to point to the same place and the php script will handle displaying the different data.

I've gotten everything to work, except "www.domain.com"

Here's the other catch: i can ping and trace-route the "www.domain.com" and the "domain.com" and everything else and they come back with successful pings and correct IP address for traceroute.

I thought it was my DNS settings at first but since ping and trace-route work i'm not sure. either way, just to put all the information out there, I currently have these settings in my DNS:
Code:
www    A    300    123.123.123.123
@        A    300    123.123.123.123
@        ns   7200  ns1.zoneedit.com
@        ns   7200  ns2.zoneedit.com
These are my current settings. I've tried using the fqdm, "www.domain.com." tried using www CNAME 7200 domain.com, tried using * A 300 123.123.123.123. Those didnt work either.

Now for my ISPConfig, I run CentOS 5.5 x64 and followed the perfect server guidelines for setting this up from this website. I should state, I am using a VPS from fanaticalvps.com as well. There were some things i wasnt able to do and found workarounds for them, but this was with BIND server, which i currently have turned off due to using zoneedit.com DNS and suPHP(i think). From what i read, this is due to the fact that I was using a vps.

In ISPConfig, I've created the website, the ftp connection for this and that all works, email works, etc. I set the website to use domains for all 3 options for subdomains, "none", "www", "*" - all actually produce the same result: all subdomains work except "www."

Any Help is appriciated. Thanks
Reply With Quote
Sponsored Links