View Single Post
  #28  
Old 12th May 2011, 00:26
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Backup your apache2.conf, make this changes:

MaxKeepAliveRequests 100
KeepAlivetimeout 15

<IfModule mpm_prefork_module>
StartServers 2
MinSpareServers 2
MaxSpareServers 3
MaxClients 45
MaxRequestsPerChild 500
</IfModule>

I am not an expert, but as I can see apache2 is eating all your memory... I don't know your entire configuration and if this could or not work for you. But I think that you must limit the resources destinated to apache, in order to evade swap (and lack of memory... see what happen in four or five days, your memory will not be enough if you let it as it is right now).

Try to see if it works better or not than before. Take note of memory consumtion and memory consumption incrementation curve (more slow? more quickly?). If you note any change, it is just a setting problem with this directives. If this not work, you always can rollback the conf file.

Restart apache2 this night, it was recently restarted, so... it must be running ok right now.

Regards
Reply With Quote