View Single Post
  #8  
Old 9th May 2006, 20:06
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,037
Thanks: 269
Thanked 154 Times in 133 Posts
Default

Quote:
Originally Posted by ColdDoT
Pleaz i need this info for the virtual apache servers realy bad.
....................................*BUMP*........ ...........................
Ok.. I got access to my home PC, and here are the notes that I made some time ago on how I did the install (of MX6, and MX7) on my server.
I'm using ISPconfig with Apache (and virtual apache servers) and Coldfusion MX7. ISPconfig is not needed to use Coldfusion with Apache.

The notes are NOT for Fedora, but I did use them to install Coldfusion on my Fedora RC4 server.
You might need to verify the Apache configuration directory, the Apache binary file directory, and the control file to start and stop Apache

Quote:
How to install Coldfusion MX 6.1.0

For Coldfusion to work You WILL also need to install:
xorg-x11
libXp.so.6 (if you get the The Graphing service is not available. error)

1) Download the 30 day demo from here:
http://download.macromedia.com/pub/c...macr-linux.bin

2) Once downloaded, chmod +x coldfusion-61-lin.bin
3) Install it with: ./coldfusion-61-lin.bin

(note. Disable you firewall when you install Coldfusion!)

At Choose Locale... select 1 for English
Press enter to continue
...
...

At the 'Do you accept the terms.." select Y
Ignore the errors/warnings about the C++ compatibility pack..
Press enter to continue

At 'Is there already a version of Macromedia MX installed on this computer' select No
At 'Install Type' select 2 for the '30-day trial version' (in my case I select 1 as I have a licensed version)
(if you selected 1, you will need to enter the serial number)

At 'What kind of installation do you want?' you select '1' for the Server configuration.

Leave the 'Absolute path' as is.. press enter to accept
At 'is there a version of coldfusion 4.5 or 5..' select n

At 'Configure web server' make sure you select 1
At 'Choice: 1' select 1 for Apache
The Apache configuration directory is: /etc/httpd/conf
The Apache binary file directory is: /usr/sbin/httpd
The control file to start and stop Apache dir is: /usr/sbin/apachectl

Select option 4 to continue with installation
You can leave the 'web root for Macromedia Coldfusion MX' as is (/var/www/html)

At 'Runtime User' you will need to enter a user name. I have created a user named coldfusion, and used that. I think you can also use 'root' as Runtime User.
At 'Would you like Coldfusion MX to start at system boot' select Yes

Now you need to set a password to control access to the coldfusion MX administration.

You will now see an 'Installation Confirmation'. Press enter to continue
With a bit of luck, Coldfusion should now install, and setup Apache to work with it.

Once installation is done, you will get a 'Installation Complete'... 'You have successfully completed the first step...' message
Press enter to exit the installer

You now need to start 'coldfusion' for the 1st time.
type: /opt/coldfusionmx/bin/coldfusion start

The coldfusion MX connector wizard, will now create the Apache connector. (the Apache connector is needed to make Apache work with Coldfusion)
After some time you should get a: 'Connector installation succeeded for apache' followed by a 'ColdFusion MX has been started' message

Now you will need to setup some things with the control access to the coldfusion MX administration.
Start you web browser and go to 'http://you_server_ip/CFIDE/administrator' and login
I'm using RDS, so I did not disable it... Enter a password if you need RDS. Click on next.
For me there was no need to install the examples, as they do not work outside my local lan (my server is in a data center). Click on next.
After this setup is completed, and Coldfusion is up and running.

All you need to do now is cleanup (delete) the 'coldfusion-61-lin.bin' file, as there is no need for it anymore.
Also. Do not forget to enable the firewall again.
Let me know if something is not clear!

Last edited by edge; 9th May 2006 at 20:34.
Reply With Quote