View Single Post
  #5  
Old 18th April 2011, 23:05
serkejal serkejal is offline
Junior Member
 
Join Date: Apr 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I found another way... from this tutorial i have changed this part
Code:
<IfModule mod_rewrite.c>
  <IfModule mod_ssl.c>
    <Location /webmail>
      RewriteEngine on
      RewriteCond %{HTTPS} !^on$ [NC]
      RewriteRule . https://%{HTTP_HOST}:50443%{REQUEST_URI}  [L]
    </Location>
  </IfModule>
</IfModule>
to this.
Code:
<IfModule mod_rewrite.c>
  <IfModule mod_ssl.c>
    <Location /webmail>
      RewriteEngine on
      RewriteCond %{HTTPS} !^on$ [NC,OR]
      RewriteCond %{HTTP_HOST} !^my\.main\.domain:50443 [NC]
      RewriteRule  . https://my.main.domain:50443%{REQUEST_URI} [R,L]
    </Location>
  </IfModule>
</IfModule>
so all domains/webmail is redirected to maindomain/webmail ..
now all the http requests are redirected properly, without certification problems.
otherwise https requests made ​​directly to domain/webmail before being redirected verify the certificate..and give the above error ...I do not think there is a solution ...
Is it ,in these cases, useful to have a wildcard certificate?
can I disable access to ISPConfig RoundCube, phpmyadmin on other domain to force everyone to pass from the primary domain?

and then are also other questions
Reply With Quote