View Single Post
  #1  
Old 16th April 2011, 10:23
eko_taas eko_taas is offline
Member
 
Join Date: Feb 2011
Posts: 92
Thanks: 2
Thanked 12 Times in 10 Posts
Default Updated to 3.0.3.3 and SSL/8080 stopped working

SSL/8080 was working earlier OK, but after updating to 3.0.3.3 (at my own risk used from panel (system / Remote actions / Do ISPConfig-update ), went OK, but also after restart ISPConfig thru SSL stopped working (unsecured OK). Otherwise seems to work OK (shows 3.0.3.3 when logged in).

I checked as per manual 6.2. ("6.2 Enabling SSL For The ISPConfig Web Interface") and all looks the same as earlier:
- certificates exists
- a2enmod ssl" gives "Module ssl already enabled"
- SSL engine extra lines in file still exists

so:
- http://server1.example.com:8080 => works
- https://server1.example.com:8080 => gives below
Quote:
Secure Connection Failed
An error occurred during a connection to server1.example.com:8080.
SSL received a record that exceeded the maximum permissible length.
(Error code: ssl_error_rx_record_too_long)
When re-starting machine, everything looks OK, but when manually restart of apache shows error
Code:
# /etc/init.d/apache2 restart
Restarting web server: apache2apache2: apr_sockaddr_info_get() failed for server1.example.com
...
 ... waiting apache2: apr_sockaddr_info_get() failed for server1.example.com
...
#
Any idea?

Webmin (with SSL) still OK (done as HOWTO)
http://www.howtoforge.net/easy-round...debian-squeeze
Reply With Quote
Sponsored Links