View Single Post
  #3  
Old 12th April 2011, 12:52
abu.hurayra abu.hurayra is offline
Junior Member
 
Join Date: Apr 2011
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Question

Quote:
Originally Posted by acrobal View Post
PHP Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 78
PHP Warning: mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63
PHP Warning: mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64
Thank you for all your answers
I think I have a problem alike :

in ispconfig/cron.log I have
Code:
PHP Warning:  mysql_connect(): Access denied for user 'ispcsrv4'@'ns1.myisp.be' (using password: YES) in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php
 on line 78
PHP Warning:  mysql_errno() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63
PHP Warning:  mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64

I tried to launch ispconfig's update.php (and second time telling it reconfigure permissions) but it didn't change anything (maybe parameter 1 ... boolean actually appeared after that)

In Master DB/ DB mysql/ Table user I have :
Code:
	Modifier 	Effacer 	ns1.myisp.be 	ispcsrv4 	*FA44CAB3F0172E7017ED9F04D7AEE769ED03D4CB 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	  	[BLOB - 0o] 	[BLOB - 0o] 	[BLOB - 0o]	0 	0 	0 	0
	Modifier 	Effacer 	10.0.10.83 	ispcsrv4 	*FA44CAB3F0172E7017ED9F04D7AEE769ED03D4CB 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	N 	  	[BLOB - 0o] 	[BLOB - 0o] 	[BLOB - 0o]	0 	0 	0 	0
Config is 1 Master + 3 DNS Servers +1 DB Server + 1 Mail Server (ns2 works AND is mirror of ns1 ..), Debian 6.0, ISPConfig 3.0

Please note that we had a bug in config : ns1 was mirror of ns2 AND ns2 was mirror of ns1 AND ns3 was mirror of ns2.
Now ns1 is not a mirror anymore..

From ispconfig interface I cannot see anything on ns1 in monitor tab..

I don't have a clue of what to do next ..

Keep on doing good work

Cheers
Abu Hurayra


Edit : Forget to tell you :
On ISPConfig Interface the status of ns1 is "ok"
Well, Maybe it's ok but it seems it don't update anymore !!

Last edited by abu.hurayra; 12th April 2011 at 12:56.
Reply With Quote