View Single Post
  #1  
Old 9th May 2006, 02:40
Dave Lane Dave Lane is offline
Junior Member
 
Join Date: Mar 2006
Location: Christchurch, New Zealand
Posts: 9
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via ICQ to Dave Lane
Default Recovering unlinked mysql databases and users...

Hi all,

I'm wondering if there is a Database Schema diagram, showing how various tables relate to each other - specifically, I want to find out how databases and database users (i.e. rows in isp_isp_datenbank table) are associated with web sites (i.e. a row in the isp_isp_web table).

A bit more information - I'm running ISPConfig 2.2.2 on an Ubuntu Breezy server. I found, after upgrading from ISPConfig 2.1.2 -> 2.2.0 that my two resellers were no longer recognised as resellers by the system (i.e. I could see their records in the interface tree, but whenever I checked their reseller details all the fields were blank or filled with default values - a look at the DB isp_isp_reseller table confirmed it was empty). The reseller account still has clients and sites, so it's functioning as would be expected, but its Limits are not held...

In an effort to remedy this (also after upgrading to 2.2.2), I simply created a new reseller with a slightly different name. I moved a test Client and Site as well as my Hostingplans to the new reseller into the appropriate "groups" and all seemed well... then I moved an actual live Client and Site... and was warned that the default Limits for the Reseller didn't allow MySQL databases... The only option was to click "next >>", and I found (according to phpMyAdmin) that the Site's 3 databases web4_db1,2,3 had been deleted from MySQL along with their respective users web4_u1,2,3...

I fixed the Reseller Limits for the new reseller and tried recreating the databases and users through the ISPConfig interface, but it started by creating web4_db4 rather than web4_db1... Looking at the ispconfig MySQL database, I could see in isp_isp_datenbank that the 3 databases and users were still defined. Even so, the the database links associating them with their web_id must've been lost as the Site's "options" tab showed no databases.

I've since manually recreated the relevant databases, users, and recovered the data from backup, but I don't see an easy way to figure out how to reassociate those databases and users to the appropriate site so that I can again manage them through the ISPConfig interface.

Any assistance would be much appreciated!
Kind regards,

Dave (in NZ)
Reply With Quote
Sponsored Links