View Single Post
  #3  
Old 27th March 2011, 05:48
teros teros is offline
Junior Member
 
Join Date: Mar 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey mate,

Yep i verified what i think the issue is...


When looking and playing around i found that if i use default config cache of /opt/var/squid/cache Squid works accepting connections etc. but i am trying to change it to /shares/Public/WWW/Squid/cache i get connections refused.

I've started /opt/bin/squid -z to create the required swap directory's in /shares/Public/Squid/cache
Run chmod -R 770 /shares/Public - to set full read write across whole directory
chown nobody:nobody /shares/Public -have also tried setting the permissions as root as described in forum posts.



Is weird the error above i've checked the permissions on both see below

/opt/var/squid
drwxr-xr-x 18 nobody nobody 4096 Mar 26 18:58 cache

dirs inside cache
drwxr-x--- 258 nobody jewab 4096 Mar 26 18:24 00

/shares/Public/WWW/Squid/cache
drwxrwx--- 18 nobody jewab 4096 Mar 26 19:16 cache




In the cache.log i can still see the following

/shares/Public/WWW/Squid/cache/swap.state: (13) Permission
FATAL: storeUfsDirOpenSwapLog: Failed to open swap log.
Reply With Quote