View Single Post
  #1  
Old 17th March 2011, 18:29
j.smith1981 j.smith1981 is offline
Member
 
Join Date: Nov 2008
Posts: 63
Thanks: 0
Thanked 3 Times in 3 Posts
Question Keep getting: access to /backuppc failed, reason: verification of user id 'backuppc'

Hello I am getting this error here:

Quote:
[Thu Mar 17 16:17:09 2011] [error] [client myipaddress] (13)Permission denied: Could not open password file: /etc/BackupPC/htpasswd
[Thu Mar 17 16:17:09 2011] [error] [client myipaddress] access to /backuppc failed, reason: verification of user id 'backuppc' not configured
When I try accessing:
http://www.mydomain.co.uk/backuppc

I have the following in my httpd.conf:

Quote:
# ScriptAlias /backuppc /usr/share/backuppc
# Alias /backuppc /usr/share/backuppc
Alias /backuppc /usr/share/backuppc

#<Directory /usr/share/backuppc/cgi-bin>
<Directory /usr/share/backuppc>
SetHandler perl-script
PerlResponseHandler ModPerl::Registry
PerlOptions +ParseHeaders
Options +ExecCGI
Order deny,allow
Deny from all
Allow from 192.168.2
AuthName "This is a restricted resource, please enter your username and password to gain access to this system:"
AuthType Basic
# AuthUserFile /var/lib/backuppc/passwd/htpasswd
AuthUserFile /etc/BackupPC/htpasswd
Require valid-user
</Directory>
I ran htpasssword using this command here:
Quote:
htpasswd -c /etc/BackupPC/htpasswd backuppc
My '/etc/BackupPC/hosts' file looks like:
Quote:
#================================================= ============ -*-perl-*-
#
# Host file list for BackupPC.
#
# DESCRIPTION
#
# This file lists all the hosts that should be backed up by
# BackupPC.
#
# Each line in the hosts file contains three fields, separated
# by white space:
#
# - The host name. If this host is a static IP address this
# must the machine's IP host name (ie: something that can
# be looked up using nslookup or DNS). If this is a DHCP
# host then the host name must be the netbios name of the
# machine. It is possible to have a host name that contains
# spaces, but that is discouraged. Escape a space with "\", eg:
#
# craigs\ pc
#
# - DHCP flag. Set to 0 if this is a static IP address host
# or if the machine can be found using nmblookup. Otherwise,
# if the client can only be found by looking through the DHCP
# pool then set this to 1.
#
# - User name (unix login/email name) of the user who "owns"
# or uses this machine. This is the user who will be sent
# email about this machine, and this user will have permission
# to stop/start/browse/restore backups for this host. This
# user name must match the name the user authenticates with
# via apache.
#
# - Optional additional user names (comma separated, no white space) of
# users who are also allowed to stop/start/browse/restore backups
# for this client via the CGI interface. These users are not sent
# email. These do not need to be valid email names; they simply
# need to match the name the user authenticates with via apache.
#
# AUTHOR
# Craig Barratt <craig@arraycomm.com>
#
# COPYRIGHT
# Copyright (C) 2001 Craig Barratt
#
# See http://backuppc.sourceforge.net.
#
#================================================= =======================

#
# The first non-comment non-empty line gives the field names and should
# not be edited!!
#
host dhcp user moreUsers # <--- do not edit this line
#farside 0 craig jill,jeff # <--- example static IP host entry
#larson 1 bill # <--- example DHCP host entry
server 1 backuppc
Where server is the hostname of server.hsmedia.co.uk and its given a dhcp static mapping address (still issued by a dhcp server though), from my very well configured router.

I keep getting the message:
Quote:
Authorization Required

This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.
In the web browser, any suggestions?

I was trying to follow this tutorial here:
http://www.howtoforge.com/linux_backuppc

I might add that I am actually running Centos 5.5 though, this probably will affect this problem but not sure what to do.

Any helps appreciated,
Jez.
Reply With Quote
Sponsored Links