View Single Post
  #3  
Old 4th March 2011, 12:16
4F2E4A2E 4F2E4A2E is offline
Junior Member
 
Join Date: Jul 2010
Posts: 9
Thanks: 2
Thanked 1 Time in 1 Post
Question change document root of any hosted web

i did currently install redmine with ispconfig 3 and just one left problem over:
i know i should not edit the vhost manually if i am using ispconfig but only this way it is working:
Code:
<Directory /home/www/xxx.com>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
      DocumentRoot /home/www/xxx.com/web/redmine/public

    ServerName xxx.com
    ServerAlias *.xxx.com
    ServerAdmin webmaster@xxx.com

    ErrorLog /var/log/ispconfig/httpd/xxx.com/error.log


    <Directory /home/www/xxx.com/web/redmine/public>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /home/www/clients/client4/web38/web/redmine/public>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

    <IfModule mod_ruby.c>
      <Directory /home/www/clients/client4/web38/web/redmine/public>
        Options +ExecCGI
      </Directory>
      RubyRequire apache/ruby-run
      #RubySafeLevel 0
      <Files *.rb>
        SetHandler ruby-object
        RubyHandler Apache::RubyRun.instance
      </Files>
      <Files *.rbx>
        SetHandler ruby-object
        RubyHandler Apache::RubyRun.instance
      </Files>
    </IfModule>
<Directory /home/www/xxx.com/web/redmine/public>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /home/www/php-fcgi-scripts/web38/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
        <Directory /home/www/clients/client4/web38/web/redmine/public>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /home/www/php-fcgi-scripts/web38/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

</VirtualHost>
after a time ispconfig alters it again back to:
Code:
<Directory /home/www/xxx.com>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
      DocumentRoot /home/www/xxx.com/web

    ServerName xxx.com
    ServerAlias *.xxx.com
    ServerAdmin webmaster@xxx.com

    ErrorLog /var/log/ispconfig/httpd/xxx.com/error.log


    <Directory /home/www/xxx.com/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /home/www/clients/client4/web38/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

    <IfModule mod_ruby.c>
      <Directory /home/www/clients/client4/web38/web>
        Options +ExecCGI
      </Directory>
      RubyRequire apache/ruby-run
      #RubySafeLevel 0
      <Files *.rb>
        SetHandler ruby-object
        RubyHandler Apache::RubyRun.instance
      </Files>
      <Files *.rbx>
        SetHandler ruby-object
        RubyHandler Apache::RubyRun.instance
      </Files>
    </IfModule>
<Directory /home/www/xxx.com/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /home/www/php-fcgi-scripts/web38/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
        <Directory /home/www/clients/client4/web38/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /home/www/php-fcgi-scripts/web38/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

</VirtualHost>
how can i set this in ispconfig?

ispconfig settings:
PHP open_basedir:
/home/www/clients/client4/web38/web/redmine/public:/home/www/clients/client4/web38/tmp:/home/www/xxx.com/web/redmine/public:/srv/www/xxx.com/web/redmine/public:/usr/share/php5:/tmp:/usr/share/phpmyadmin

please help
Reply With Quote