View Single Post
  #4  
Old 25th February 2011, 13:25
autogun autogun is offline
Member
 
Join Date: Sep 2009
Posts: 69
Thanks: 9
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by till View Post
Thats no bug. It is intended that the line is commented out as this kind of configuration does not work for mod_php when you have more then one vhost on a server that has this configuration line in the vhost file. If this line is active in a second vhost, then apache will not start anymore. The reason for that is simple, php can load only one configuration per process, as all websites with mod_php share the same process, there can only be one php.ini for all mod_php websites.

The custom php.ini settings are only for php-cgi, php-fcgi and suphp as explained in the manual, chapter 4.6.1.1. For mod_php, use the php_admin_flag and php_value options of the mod_php module in the apache directives field.
Hello till,

Thank you very much for clarifying this to me, I know this is my fault - not reading the manual.

Just a little suggestion, there is plenty of space under the "Custom php.ini settings" where this can be pointed out. Something like "Works only with php-cgi, php-fcgi and suphp - refer to the manual for more info" or something alike.

Thanks again!
Reply With Quote