View Single Post
  #7  
Old 22nd February 2011, 21:05
itsnedkeren itsnedkeren is offline
Senior Member
 
Join Date: May 2009
Location: Denmark
Posts: 128
Thanks: 32
Thanked 10 Times in 10 Posts
Default

I think I have the recipe now

Prerequisites:

1) Backup /usr/share/pyshared/baruwa/settings.py
2) Follow below

#cd /usr/src
#rm baruwa-doc_1.0.1-1_all.deb baruwa_1.0.1-1_all.deb
# wget http://topdog-software.com/oss/baruw....0.2-1_all.deb
#wget http://topdog-software.com/oss/baruw....0.2-1_all.deb
#gdebi baruwa*.deb <- SELECT NO TO DATABASE CONFIG!!
#reboot
#cd /usr/src/
#ln -s /opt/MailScanner-4.81.4-1/ /opt/MailScanner
#./mailscanner.sh
#/etc/init.d/mailscanner start
#/etc/init.d/postfix start

3) Copy your backed up "settings.py" to /usr/share/pyshared/baruwa

4) Reboot (might not be neccesary)

5) Profit?

Disclaimer: This worked for me, but I do NOT guarantee it will work for you!

EDIT: Functions such as deleting an "Auth server" from a domain, still causes errors, but the AJAX errors seems to be solved.
Code:
AttributeError at /settings/auth/2/delete/

'NoneType' object has no attribute 'widget'

Request Method: 	POST
Request URL: 	http://mailgw.domain.tld/settings/auth/2/delete/
Django Version: 	1.2.3
Exception Type: 	AttributeError
Exception Value: 	

'NoneType' object has no attribute 'widget'

Exception Location: 	/usr/lib/pymodules/python2.6/django/forms/forms.py in _clean_fields, line 278
Python Executable: 	
Python Version: 	2.6.6
Python Path: 	['.', '', '/usr/lib/python2.6', '/usr/lib/python2.6/plat-linux2', '/usr/lib/python2.6/lib-tk', '/usr/lib/python2.6/lib-old', '/usr/lib/python2.6/lib-dynload', '/usr/local/lib/python2.6/dist-packages', '/usr/lib/python2.6/dist-packages', '/usr/lib/python2.6/dist-packages/PIL', '/usr/lib/pymodules/python2.6', '/usr/lib/pymodules/python2.6/gtk-2.0']
Server time: 	Tue, 22 Feb 2011 15:13:49 -0500
__________________
Best regards

Jim

Last edited by itsnedkeren; 22nd February 2011 at 21:15.
Reply With Quote