View Single Post
Old 9th February 2011, 18:56
gummiv gummiv is offline
Junior Member
Join Date: Feb 2011
Location: Iceland
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default FTP problem, ISPConfig

Hey there,

Im new to Linux but got directed towards ISPConfig by a friend when I needed a hosting solution for another friend.
I went through the guide provided here:

I followed it to the letter and everything seemed to go smoothly. I could create a client and a site within ISPConfig. The site worked and I could publish stuff on it. I ran into problems when I wanted to create an ftp user for the site. I created the ftp user within ISPConfig and it is marked as active.
When I try to ftp via this user I created, I get the following message within my ftp client:

Status: Connecting to 555.555.555.555...
Response: fzSftp started
Command: open "user1@555.555.555.555" 22
Command: Pass: ********
Error: Authentication failed.
Error: Critical error
Error: Could not connect to server

When I try to ftp in as root, that works without problems (even though root is located within /etc/ftpusers)

I checked the auth.log and found this, when trying to ftp in with the user I created:

sshd[18060]: Invalid user **** from
sshd[18060]: Failed none for invalid user **** from port 53982 ssh2
sshd[18060]: pam_unix(sshd:auth): check pass; user unknown
sshd[18060]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=

So Im thinking if ISPConfig did not create the user within the ftp server itself?
At this moment Im stuck since I cant provide the users with ftp access so they are unable to work on setting their site up.

Any help with this would be greatly appreciated.
Reply With Quote
Sponsored Links