View Single Post
  #1  
Old 7th February 2011, 13:21
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Default Upgrading an ISPConfig3 server from Debian Lenny to Squeeze

During the upgrade of my ISPConfig3 testing-server from Debian Lenny to Squeeze, one problem occurred:
MySQL-server-5.1 could not start.

This happend, because during the upgrade to MySQL-server5.1, i chose to keep my own /etc/my.cnf file.
After some investifation, i found out that that the line "skip-bdb" within this file was the cause of this.

So, if you prepair an upgrade from Lenny to Squeeze and your /etc/my.cnf file contains the line "skip-bdb", please comment it out by placing a hash-tag (#) in front of this line.
Then your upgrade to MySQL-server5.1 will be succesful!

Hope this info will help others too.
__________________
Hans

MrHostman | Master in managed hosting
Reply With Quote
Sponsored Links