View Single Post
  #1  
Old 5th May 2006, 15:26
rocket30 rocket30 is offline
Junior Member
 
Join Date: May 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default The Perfect Xen 3.0 Setup For Debian | IPTABLES

I took the compile-your-own-kernel route and iptables is not working on vm01.

This is what shows on dm0:

dm0:/# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination
ACCEPT all -- anywhere anywhere PHYSDEV match --physdev-in vif4.0

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
dm0:/# iptables --list
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination
ACCEPT all -- anywhere anywhere PHYSDEV match --physdev-in vif4.0

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
dm0:/#


This is what shows on vm01:

vm01:/# iptables -L
Note: /etc/modules.conf is more recent than /lib/modules/2.6.12.6-xenU/modules.d ep
modprobe: QM_MODULES: Function not implemented

modprobe: QM_MODULES: Function not implemented

modprobe: Can't locate module ip_tables
iptables v1.2.11: can't initialize iptables table `filter': iptables who? (do yo u need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
vm01:/#


From dm0 I display iptables kernel options for xen0 and xenU:

dm0:/# cat /boot/config-2.6.12.6-xen0 | grep -i "IPTABLES"
CONFIG_IP_NF_IPTABLES=m
dm0:/# cat /boot/config-2.6.12.6-xenU | grep -i "IPTABLES"
CONFIG_IP_NF_IPTABLES=m
dm0:/#



Any suggestions on how to fix iptables on vm01?
Reply With Quote
Sponsored Links