View Single Post
  #5  
Old 2nd February 2011, 23:36
MrCompTech MrCompTech is offline
Member
 
Join Date: Jul 2010
Posts: 92
Thanks: 1
Thanked 20 Times in 9 Posts
Default

Well it took a while but I did find an RPM to install the previous version of dovecot. But, that didn't work either, becuase the OS upgrade which included the dovecot upgrade also updated file needed by dovecot!

Code:
[root@prl-ofc-s01 ~]# yum install dovecot-1.2.16-1.el5.x86_64.rpm
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Examining dovecot-1.2.16-1.el5.x86_64.rpm: 1:dovecot-1.2.16-1.el5.x86_64
Marking dovecot-1.2.16-1.el5.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package dovecot.x86_64 1:1.2.16-1.el5 set to be installed
--> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15)(64bit) for package: 1:dovecot-1.2.16-1.el5.x86_64
--> Processing Dependency: libcrypto.so.6()(64bit) for package: 1:dovecot-1.2.16-1.el5.x86_64
--> Processing Dependency: libdb-4.3.so()(64bit) for package: 1:dovecot-1.2.16-1.el5.x86_64
--> Processing Dependency: libldap-2.3.so.0()(64bit) for package: 1:dovecot-1.2.16-1.el5.x86_64
--> Processing Dependency: libmysqlclient.so.15()(64bit) for package: 1:dovecot-1.2.16-1.el5.x86_64
--> Processing Dependency: libpq.so.4()(64bit) for package: 1:dovecot-1.2.16-1.el5.x86_64
--> Processing Dependency: libssl.so.6()(64bit) for package: 1:dovecot-1.2.16-1.el5.x86_64
--> Finished Dependency Resolution
Error: Package: 1:dovecot-1.2.16-1.el5.x86_64 (/dovecot-1.2.16-1.el5.x86_64)
           Requires: libmysqlclient.so.15(libmysqlclient_15)(64bit)
Error: Package: 1:dovecot-1.2.16-1.el5.x86_64 (/dovecot-1.2.16-1.el5.x86_64)
           Requires: libdb-4.3.so()(64bit)
Error: Package: 1:dovecot-1.2.16-1.el5.x86_64 (/dovecot-1.2.16-1.el5.x86_64)
           Requires: libldap-2.3.so.0()(64bit)
Error: Package: 1:dovecot-1.2.16-1.el5.x86_64 (/dovecot-1.2.16-1.el5.x86_64)
           Requires: libssl.so.6()(64bit)
Error: Package: 1:dovecot-1.2.16-1.el5.x86_64 (/dovecot-1.2.16-1.el5.x86_64)
           Requires: libpq.so.4()(64bit)
Error: Package: 1:dovecot-1.2.16-1.el5.x86_64 (/dovecot-1.2.16-1.el5.x86_64)
           Requires: libcrypto.so.6()(64bit)
Error: Package: 1:dovecot-1.2.16-1.el5.x86_64 (/dovecot-1.2.16-1.el5.x86_64)
           Requires: libmysqlclient.so.15()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Oh this is painful!
Reply With Quote