View Single Post
  #1  
Old 2nd February 2011, 20:29
scottrill2 scottrill2 is offline
HowtoForge Supporter
 
Join Date: Dec 2009
Posts: 93
Thanks: 21
Thanked 2 Times in 1 Post
Default ISPConfig 3 configuration

I am installing ISPConfig 3 and everything was working fine, I hadnt transferred any sites from ISPConfig 2 yet, but could log into control panel and play around etc.


I was wanting to enable SSL and SuExec for conmtrol panel per the manual on pages 296-298. Enabled SSL just fine logged into control panel, SSL is working etc.


**A note about SSL in the manual it says to find the tags that are labeled "<VirtualHost &hellip;.></VirtualHost>" Im assuming the part that reads "&hellip;." is a typo, in my file I only have one set of tags and thats "<VirtualHost _default_:8080></VirtualHost>". Or was I supposed to make a new set of tags. SSL did work afterwards, so Im assuming that was correct.


But when I tried enabling SuExec I ran into problems.

I did the following:

vi /etc/apache2/sites-available/ispconfig.vhost
**Commented out the entire "<IfModule mod_php5.c>" section

rm -f /var/www/ispconfig

/etc/init.d/apache2 restart

After the restart it says:

server3:~# /etc/init.d/apache2 restart
Restarting web server: apache2Warning: DocumentRoot [/var/www/ispconfig/] does not exist... waiting Warning: DocumentRoot [/var/www/ispconfig/] does not exist.
server3:~#

Then when I try and log into the control panel I get a 403 Forbidden error.

What did I screw the pooch on folks?


Thanks as always for your time,

Scott
Reply With Quote
Sponsored Links