View Single Post
  #1  
Old 2nd February 2011, 05:03
MrCompTech MrCompTech is offline
Member
 
Join Date: Jul 2010
Posts: 92
Thanks: 1
Thanked 20 Times in 9 Posts
Default POP3 no longer works after system upgrade

After upgrading server from Fedora Core 13 to 14 I can no longer log in to the mail server using webmail (imap) or Thunderbird (POP3).

When I try with Thunderbird/POP3 is receive the error message:

Sending of username did not succeed. Mail server 192.168.1.10 responded: Plaintext authentication disallowed on non-secure (SSL/TLS) connections

I changed the dovecot.conf file and added :
disable_plaintext_auth = no

Restart dovecot and try using Thunderbird/POP3 again and receive the error message:

Sending of password dod not succedd. Mail server 192.168.1.10 responded: Authentication failed.

Get an option to enter the password again but still get the same error.
Went into the ISPConfig control panel and put the password in again but still get 'Authentication failed'.

The system upgrade apparently included upgrading dovecot!

I replaced the new dovecot.conf with my old one and get these errors and the service fails to start:

Code:
Starting Dovecot Imap: doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:20: protocols=imaps is no longer necessary, remove it
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:20: protocols=pop3s is no longer necessary, remove it
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:560: mail_executable has been replaced by service { executable }
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:631: mail_executable has been replaced by service { executable }
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:715: protocol managesieve {} has been replaced by protocol sieve { }
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:890: add auth_ prefix to all settings inside auth {} and remove the auth {} section completely
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:928: passdb pam {} has been replaced by passdb { driver=pam }
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:1007: passdb sql {} has been replaced by passdb { driver=sql }
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:1044: userdb passwd {} has been replaced by userdb { driver=passwd }
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:1089: userdb sql {} has been replaced by userdb { driver=sql }
doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:1110: auth_user has been replaced by service auth { user }
doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf: ssl enabled, but ssl_cert not set
So the dovecot.conf files are no longer compatible, so I but the new back in place of the old which was how is was after the upgrade.

I ran doveconf -n > dovecot-new.conf and copied this to dovecot.conf but that has not fixed the problem.

Any suggestions?
Reply With Quote
Sponsored Links