View Single Post
Old 24th January 2011, 05:30
Ovidiu Ovidiu is offline
Senior Member
Join Date: Sep 2005
Posts: 1,269
Thanks: 84
Thanked 25 Times in 21 Posts
Default yet another apache2 tuning thread

The problem seems to be memory. Running Debian latest with ispcfg3. tried optimizing apache, then placed nginx as a front-end proxy still the same problem. details about the server can be found here, its nice graphs and you will see the dire memory probs I am having:

server details:

model name : Dual-Core AMD Opteron(tm) Processor 1214 HE
stepping : 3
cpu MHz : 2200.000
cache size : 1024 KB

cat /proc/meminfo
MemTotal: 4047116 kB
MemFree: 944716 kB
Buffers: 118796 kB
Cached: 1522848 kB
SwapCached: 407656 kB
Active: 2422260 kB
Inactive: 529960 kB
SwapTotal: 2104496 kB
SwapFree: 1046996 kB

current situation:

total used free shared buffers cached
Mem: 4047116 3219260 827856 0 118808 1555688
-/+ buffers/cache: 1544764 2502352
Swap: 2104496 1057392 1047104

running about 7-8 low traffic sites, mostly wordpress based. most of the sites didn't have more than 2GB of traffic the whole last year. only one of them had 30GB traffic over the last year.
One of them sends out a daily newsletter at night to about 8000 recipients.

current status looks like this:

ls /etc/apache2/mods-enabled/
actions.conf alias.load authz_default.load authz_user.load cgi.load dir.conf fcgid.conf headers.load mime.load php5.conf rpaf.conf setenvif.conf ssl.load suexec.load
actions.load auth_basic.load authz_groupfile.load autoindex.conf deflate.conf dir.load fcgid.load include.load negotiation.conf php5.load rpaf.load setenvif.load status.conf suphp.conf
alias.conf authn_file.load authz_host.load autoindex.load deflate.load env.load headers.conf mime.conf negotiation.load rewrite.load ruby.load ssl.conf status.load suphp.load

please also see screenshots.

Please let me know if you need more info or if you have any suggestions.
Reply With Quote
Sponsored Links